Page 1 of 1

Image that doesn't belong to a TV series

PostPosted: Wed Nov 09, 2016 10:13 pm
by kfir-hadas
Hello,

I'm using an Android app for tracking TV series, and it uses FanArt.tv's API to display show logos.
There is a weird case where the logo displayed in the app, is of another movie (not even a TV series).
The series is 'Code Black', ID 295780 (Link to the FanArt page)
As you can see there is one image under 'HD CLEARLOGO', been there for a year now - that's okay.

The problem is when that app is requesting data from the API, as you can see here: example of an API request for 'Code Black' FanArt
The 'hdtvlogo' on that example refers to a logo of 'The 33' movie, although the link is to a file named 'code-black-55e1d2035d93e.png'.

All the other images in the API call are in the right place, just the logo isn't...
I found that same problem after looking at an API request for 'The 33' movie, by checking the English 'hdmovielogo' entry which is actually a 'Brooklyn Nine-Nine' TV logo...
Of-course like the first case, on the FanArt page it looks fine.

For your inspection :)
Thank you.

Re: Image that doesn't belong to a TV series

PostPosted: Fri Nov 11, 2016 4:12 pm
by Kode
Happy to look into it if you can give me some API request urls that are being called?

Re: Image that doesn't belong to a TV series

PostPosted: Fri Nov 11, 2016 4:22 pm
by kfir-hadas
Kode wrote:Happy to look into it if you can give me some API request urls that are being called?


Maybe I don't understand you correctly, but I put two API requests on the original post:
1. TV Show Code Black where the logo doesn't belong to the show.
2. Movie The 33 where the logo is of another movie.

If you meant something else, I'll be happy to help once I understand...
P.S
I'm not a developer, just an app & site user...

EDIT
After looking at another topic in this forum, I tried to clear my cache.
Both logos keep changing every time I do a "hard refresh" (Shift+F5)
Only by adding https:// to the link I can get the right logos... (Code Black / The 33)