Use your fanart.tv username and password to login to this forum, if you don't have one, clicking on register will take you to the registration form on fanart.tv

More Api Problems

Post here any issues with the API or feature requests

More Api Problems

Postby sysv » Thu Dec 08, 2016 10:33 pm

Well the api continues to give me a headache pasting this into a web page i get

"http://webservice.fanart.tv/v3.1/music/b071f9fa-14b0-4217-8e97-eb41da73f598?api_key=<api_key>"

Error 520 Ray ID: 30e34a1b00b01bbb • 2016-12-08 21:25:22 UTC
Web server is returning an unknown error

Or this json result

{
"status": "error",
"error message": "API key is invalid or disabled"
}

Or on occasion ( which is perhaps one in 10 tries)
the proper result

my qt/qml app i am working on gives this immediate response a lot of the time
- server replied: Origin Error"

Anyone help
sysv
 
Posts: 8
Joined: Mon Dec 05, 2016 6:32 pm

Re: More Api Problems

Postby Kode » Mon Dec 12, 2016 1:10 pm

I had to remove the VPS servers as we had issues with them, so was running on 1 main server + 1 VPS, unfortunately the load to the API caused OVH to decide that the VPS was being attacked and dropping traffic, the servers are in round robin so when trying to hit the VPS I think that is where the cloudflare 520 error was coming from, I have added another 3 VPS's to try and share the load, see if that helps, I would suggest if you hit a 520 it might be worth pausing for 10 seconds before trying again as you will probably have cached the DNS and so will keep hitting the same server.
User avatar
Kode
Site Admin
Site Admin
 
Posts: 346
Joined: Wed Dec 18, 2013 11:34 am

Re: More Api Problems

Postby sysv » Mon Dec 12, 2016 11:29 pm

ok thanks for the info. its nice to get a response. hopefully this will work. today i have seen no errors. Sat/Sun are the days that i get very little or no results

thanks again
sysv
 
Posts: 8
Joined: Mon Dec 05, 2016 6:32 pm

Re: More Api Problems

Postby sysv » Sat Jan 21, 2017 5:12 am

Hey Kode took some time off from working on my app but see that a month later the problem as stated above remains
unresolved. Here is another error msg like before


Error 502 Ray ID: 3247c7fa54c30c41 • 2017-01-21 03:46:48 UTC
Bad gateway
You
Browser
Working
Seattle
CloudFlare
Working
webservice.fanart.tv
Host
Error

Get this perhaps 8 out of 10 tries tonite. I use the images from here for backgrounds,cd artwork,banners for my player which by design won't start till the images are loaded. Waiting 15 secs or more to flush the dns cache just isn't a viable option. i can wait a very long time at times And at this point in time i do not even know if there is a way to do this with qtnetworkmanager. Any Suggestions? Does VIP membership give me means to get my net request in without failure? Would storing the background,cd,banner url's on my side help? Any suggestions?
sysv
 
Posts: 8
Joined: Mon Dec 05, 2016 6:32 pm

Re: More Api Problems

Postby Kode » Sun Jan 22, 2017 12:55 am

Man, these VPS are flakey as hell =/

See how you get on now, I've spent the last 4+ hours trying to get it sorted out, ditched the VPSs and it's now running on the main API server plus an extra dedicated server.
User avatar
Kode
Site Admin
Site Admin
 
Posts: 346
Joined: Wed Dec 18, 2013 11:34 am

Re: More Api Problems

Postby sysv » Sun Jan 22, 2017 2:22 am

Ok looks good now. Will be testing more tomorrow


Thanks
sysv
 
Posts: 8
Joined: Mon Dec 05, 2016 6:32 pm

Re: More Api Problems

Postby sysv » Sun Jan 22, 2017 11:24 pm

Update:
No Problems again to day

Thanks again
sysv
 
Posts: 8
Joined: Mon Dec 05, 2016 6:32 pm


Return to API

Who is online

Users browsing this forum: No registered users and 7 guests

cron