Use your fanart.tv username and password to login to this forum, if you don't have one, clicking on register will take you to the registration form on fanart.tv

520 web server error

Post here any issues with the API or feature requests

520 web server error

Postby macbellota » Sun Jun 18, 2017 5:00 pm

During all day today when making a call to the api I get "webservice.fanart.tv | 520: Web server is returning an unknown error"

You are working in the api ?, had not had problems until today of this type.
macbellota
 
Posts: 3
Joined: Sun Jun 18, 2017 4:58 pm

Re: 520 web server error

Postby EmberMediaManager » Mon Jun 19, 2017 8:38 am

Same here: "520 Origin Error"

Any news about this issue?
EmberMediaManager
 
Posts: 12
Joined: Thu May 15, 2014 9:07 pm

Re: 520 web server error

Postby CineZone » Tue Jun 20, 2017 2:05 am

Having the same effect since a few days.
I'm surprised that only two people have reported this problem yet.
Maybe it's a regional problem that does not affect all users?
I'm getting 520 and 504 errors.
Problem seems to be the connection between Cloudflare (Hamburg in my case) and fanart.tv.
Would be great to get some infos about this issue.
CineZone
 
Posts: 6
Joined: Mon Jun 19, 2017 9:40 am

Re: 520 web server error

Postby telexxingou » Tue Jun 20, 2017 6:24 am

Same here from France.....
This morning : 403 forbidden :cry:
telexxingou
 
Posts: 3
Joined: Tue Jun 20, 2017 6:23 am

Re: 520 web server error

Postby Kode » Tue Jun 20, 2017 9:10 am

Can you PM me a request you are trying?
User avatar
Kode
Site Admin
Site Admin
 
Posts: 347
Joined: Wed Dec 18, 2013 11:34 am

Re: 520 web server error

Postby Kode » Tue Jun 20, 2017 10:15 am

Is this resolved now? Cloudflare have recently been complaining how much data they have had to proxy for us (over 17 billion requests a month), so they may have started restricting the traffic. I have changed webservice to DNS only, however, we were using cloudflare for SSL certificates so I had to set up letsencrypt on the server, but it is only working on 1 of the servers for some reason, so I have switched webservice to a single server for now, let's see how it gets on, it should be fine.

*edit* or it could just have been the second server playing up, causing these issues, either way, hopefully it should be ok now
User avatar
Kode
Site Admin
Site Admin
 
Posts: 347
Joined: Wed Dec 18, 2013 11:34 am

Re: 520 web server error

Postby McStarfighter » Tue Jun 20, 2017 10:34 am

Kode wrote:Is this resolved now? Cloudflare have recently been complaining how much data they have had to proxy for us (over 17 billion requests a month), so they may have started restricting the traffic. I have changed webservice to DNS only, however, we were using cloudflare for SSL certificates so I had to set up letsencrypt on the server, but it is only working on 1 of the servers for some reason, so I have switched webservice to a single server for now, let's see how it gets on, it should be fine.

*edit* or it could just have been the second server playing up, causing these issues, either way, hopefully it should be ok now


At the moment Emby Server & MediaElch & Ember Media Manager & Kodi aren't able to get any artwork from fanart.tv, so your changes seems doesn't help ... :(
McStarfighter
 
Posts: 4
Joined: Tue Jun 20, 2017 10:32 am

Re: 520 web server error

Postby Kode » Tue Jun 20, 2017 11:02 am

They might have cached the issue? It should definitely be fixed, but if not I need more information on the issues they are getting.
User avatar
Kode
Site Admin
Site Admin
 
Posts: 347
Joined: Wed Dec 18, 2013 11:34 am

Re: 520 web server error

Postby McStarfighter » Tue Jun 20, 2017 11:17 am

Kode wrote:They might have cached the issue? It should definitely be fixed, but if not I need more information on the issues they are getting.


I see multiple 500 errors in the Emby Server logs!
McStarfighter
 
Posts: 4
Joined: Tue Jun 20, 2017 10:32 am

Re: 520 web server error

Postby telexxingou » Tue Jun 20, 2017 11:48 am

All is working now :)

Thanks
telexxingou
 
Posts: 3
Joined: Tue Jun 20, 2017 6:23 am

Next

Return to API

Who is online

Users browsing this forum: No registered users and 2 guests