Use your fanart.tv username and password to login to this forum, if you don't have one, clicking on register will take you to the registration form on fanart.tv

Cannot use API_key after generating

Post here any issues with the API or feature requests

Cannot use API_key after generating

Postby nikita_97_10 » Sat Jun 06, 2015 9:56 pm

I have the same problem as it was described here:
viewtopic.php?f=4&t=330
But I still don`t understand how to solve it. I just registered and generated a key, but I`m getting this problem: "API key is invalid or disabled"
URL:
http://webservice.fanart.tv/v3/music/16 ... 6?api_key=<generated api_key here>
Maybe client_key is requred to use API? If so, where can I find it?

Edit: May be I should use generated API key as client_key and as api_key I should use key shown in API documentation? It works, but I`m not sure it`s correct
nikita_97_10
 
Posts: 5
Joined: Sat Jun 06, 2015 9:51 pm

Re: Cannot use API_key after generating

Postby Kode » Mon Jun 08, 2015 2:32 pm

Did you generate a personal key or a project api key here: https://fanart.tv/get-an-api-key/ ?

A project key is used where it asks for api_key and personal key is used where it asks for client_key

Hope that helps
User avatar
Kode
Site Admin
Site Admin
 
Posts: 353
Joined: Wed Dec 18, 2013 11:34 am

Re: Cannot use API_key after generating

Postby lsampaio » Mon Jun 08, 2015 4:14 pm

Hi,

I have the same issue, just created an api key on the url you mentioned and when I try to execute a Get I have the following response:

http://webservice.fanart.tv/v3/tv/75682?api_key=<KEY>

{
"status": "error",
"error message": "API key is invalid or disabled"
}

Would you know what is going on?
thanks :)
lsampaio
 
Posts: 3
Joined: Mon Jun 08, 2015 4:09 pm

Re: Cannot use API_key after generating

Postby nikita_97_10 » Mon Jun 08, 2015 4:44 pm

Hi Kode, I generated a project key. I tried to use it as api_key, but I got a error. I hadn`t tried to use a personal key as a client_key at the same time because I thought client_key is optional. I`ll check it
nikita_97_10
 
Posts: 5
Joined: Sat Jun 06, 2015 9:51 pm

Re: Cannot use API_key after generating

Postby nikita_97_10 » Mon Jun 08, 2015 4:46 pm

Wow, forget everything, my API_key now works, maybe it just wasn`t activated. Works so: http://webservice.fanart.tv/v3/music/16 ... 6?api_key= <generated api_key here>
nikita_97_10
 
Posts: 5
Joined: Sat Jun 06, 2015 9:51 pm

Re: Cannot use API_key after generating

Postby lsampaio » Mon Jun 08, 2015 6:27 pm

Hi nikita_97_10,

Did you activate it or it was activated automatically? Do you know how long it take?

Thanks,
lsampaio
 
Posts: 3
Joined: Mon Jun 08, 2015 4:09 pm

Re: Cannot use API_key after generating

Postby nikita_97_10 » Tue Jun 09, 2015 5:44 am

Two days ago it wasn`t working, yesterday it was, I`m not sure when it was activated
nikita_97_10
 
Posts: 5
Joined: Sat Jun 06, 2015 9:51 pm

Re: Cannot use API_key after generating

Postby nikita_97_10 » Tue Jun 09, 2015 5:46 am

Have ypu denerated a project or personal key?
nikita_97_10
 
Posts: 5
Joined: Sat Jun 06, 2015 9:51 pm

Re: Cannot use API_key after generating

Postby Kode » Tue Jun 09, 2015 9:16 am

Hi all, we had an issue with the API database being out of sync with the live database, this is why recently generated keys were not working, they should be back in alignment soon, if not already.

client/personal key IS optional.
User avatar
Kode
Site Admin
Site Admin
 
Posts: 353
Joined: Wed Dec 18, 2013 11:34 am

Re: Cannot use API_key after generating

Postby lsampaio » Tue Jun 09, 2015 2:55 pm

It is working now :) Thanks for your help!!!
lsampaio
 
Posts: 3
Joined: Mon Jun 08, 2015 4:09 pm


Return to API

Who is online

Users browsing this forum: No registered users and 1 guest