Use your fanart.tv username and password to login to this forum, if you don't have one, clicking on register will take you to the registration form on fanart.tv

Backdrop language issue (Emby)

Backdrop language issue (Emby)

Postby happy2play » Thu Feb 02, 2017 9:19 pm

Inquiring on behalf of Emby, since the change to Backdrops language being none or lang "00" Emby does not return new backdrops since it is still language specific, as are your older images. So there a plan to normalize all backdrops to be language neutral?


Example of new
"moviebackground": [
{
"id": "164047",
"url": "http://assets.fanart.tv/fanart/movies/343611/moviebackground/jack-reacher-never-go-back-57d66ec82897d.jpg",
"lang": "00",
"likes": "4"
}

and Old
"moviebackground": [
{
"id": "20936",
"url": "http://assets.fanart.tv/fanart/movies/8452/moviebackground/the-6th-day-50eae445aa466.jpg",
"lang": "en",
"likes": "3"
}

https://emby.media/community/index.php? ... -download/
happy2play
 
Posts: 4
Joined: Thu Feb 02, 2017 9:05 pm

Re: Backdrop language issue (Emby)

Postby Esky » Fri Feb 03, 2017 12:26 am

Hi,

I've been on at Kode for ages to do a global update of all TV & Movie background images and set the language to: None (Which I guess equates to 00 for the API as you have mentioned)

It affects the results from Ember MediaManager in the same way.

The music backdrops are already defaulted to None.

Kode - you listening bud ?!?!

:D

Esky

PS. I've moved this topic to the BUGS section as he monitors this more frequently.
User avatar
Esky
Veteran
Veteran
 
Posts: 127
Joined: Mon May 26, 2014 3:42 pm
Location: UK

Re: Backdrop language issue (Emby)

Postby happy2play » Sun Feb 19, 2017 9:59 am

Doesn't look like Kode has been here in awhile.
happy2play
 
Posts: 4
Joined: Thu Feb 02, 2017 9:05 pm

Re: Backdrop language issue (Emby)

Postby Kode » Tue Feb 21, 2017 11:06 am

I'm on the IRC channel every day, I can do an update, but not really sure of the implications of this? Are *all* TV & Movie background images language neutral?
User avatar
Kode
Site Admin
Site Admin
 
Posts: 344
Joined: Wed Dec 18, 2013 11:34 am

Re: Backdrop language issue (Emby)

Postby Esky » Tue Feb 21, 2017 8:23 pm

Yes they are.

Ideally they should default to: None (as opposed to '- Not Set -') as the scrapers I'm aware of have Language filters that can be set either to country language or 'None'

For example, I did try changing some of the older images from English/German etc. but when selecting 'None' via the moderator portal, the value actually becomes '- Not Set -' which means the images don't get picked up by the scrapers.
User avatar
Esky
Veteran
Veteran
 
Posts: 127
Joined: Mon May 26, 2014 3:42 pm
Location: UK

Re: Backdrop language issue (Emby)

Postby happy2play » Wed Feb 22, 2017 4:01 am

Kode wrote:I'm on the IRC channel every day, I can do an update, but not really sure of the implications of this? Are *all* TV & Movie background images language neutral?

Can't get on Emby's forum right to get Lukes exact words, but I know he would prefer a null value instead of lang "00".

Added Luke's quote.

yea it would just make things easier for everyone that uses fanart if they would make sure the unset language is always null (empty), instead of 00 or anything else.
happy2play
 
Posts: 4
Joined: Thu Feb 02, 2017 9:05 pm

Re: Backdrop language issue (Emby)

Postby happy2play » Thu Mar 16, 2017 1:19 am

Any update on this? There is still a mixed environment.

mixed.jpg
mixed.jpg (246.78 KiB) Viewed 573 times
happy2play
 
Posts: 4
Joined: Thu Feb 02, 2017 9:05 pm

Re: Backdrop language issue (Emby)

Postby Kode » Thu Mar 16, 2017 9:28 am

I'm still not sure what you all want me to set the value to, lol, Esky says to set it to 00 (which is what none is defined as) and happy2play says it should be a null value (which isn't actually an option, but I could manually do it in the database)
User avatar
Kode
Site Admin
Site Admin
 
Posts: 344
Joined: Wed Dec 18, 2013 11:34 am

Re: Backdrop language issue (Emby)

Postby Kode » Thu Mar 16, 2017 9:54 am

I've now replaced them all with empty values as I think that's how the music section deals with it, and it's easier for new uploads for it to be empty

*edit* Language dropdown has also been removed from backgrounds for future uploads
User avatar
Kode
Site Admin
Site Admin
 
Posts: 344
Joined: Wed Dec 18, 2013 11:34 am


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest