Use your fanart.tv username and password to login to this forum, if you don't have one, clicking on register will take you to the registration form on fanart.tv

imdb_id wrong or missing

Please report any errors you you see on the site related to the Database

imdb_id wrong or missing

Postby aussie_huddo » Wed Mar 08, 2017 6:17 am

I have noticed a few files in my kodi library that won't automatically download their logos and other artwork. I did a little digging and it the "artwork downloader" script can't find them as it is using imdb id values to look them up and they are wrong or missing.

The movies are:

Kubo and the Two Strings; missing imdb_id: tt4302938
Clear History; wrong imdb_id, should be: tt2279864
La La Land; missing imdb_id: tt3783958 (this has been fixed in the last few days proving that something can be done on this end)
Batman: Return of the Caped Crusaders; missing imdb_id: tt5973626
Justice League: Gods and Monsters; missing imdb_id: tt4324302
Mike and Dave Need Wedding Dates; wrong imdb_id, should be: tt2823054
My Scientology Movie; missing imdb_id: tt5111874
Blair Witch; wrong imdb_id, should be: tt1540011

How are these imdb id's set? is it possible to refresh them for all files in the fanart.tv database to avoid these errors?

cheers
Last edited by aussie_huddo on Mon Mar 13, 2017 8:21 am, edited 6 times in total.
aussie_huddo
 
Posts: 11
Joined: Sat Mar 21, 2015 7:27 am

Re: imdb_id wrong or missing

Postby shevman » Wed Mar 08, 2017 7:47 am

Fanart does not work with the ID from IMDb!
All ID Fanart comes from TMDb
User avatar
shevman
Moderator
Moderator
 
Posts: 83
Joined: Thu Mar 20, 2014 8:34 pm

Re: imdb_id wrong or missing

Postby aussie_huddo » Wed Mar 08, 2017 8:20 am

shevman wrote:Fanart does not work with the ID from IMDb!
All ID Fanart comes from TMDb


I know this, however, the Artwork Downloader script for Kodi seems to use the IMDB ID to look up the artwork.

The url it checks is like the one below (for La La Land):

http://webservice.fanart.tv/v3/movies/t ... 284d46bd8e

as you can see it returns an error.

When manually changing the IMDB ID to the TMDB ID it shows there is no IMDB ID assigned to this movie.

http://webservice.fanart.tv/v3/movies/3 ... 284d46bd8e

As such the Artwork Downloader script can not find the artwork for movies like this.
aussie_huddo
 
Posts: 11
Joined: Sat Mar 21, 2015 7:27 am

Re: imdb_id wrong or missing

Postby shevman » Wed Mar 08, 2017 11:33 am

I think the question you need to ask on the Kodi forum and not on Fanart.

But perhaps here there is someone of the members, which may say something about the "Artwork Downloader script" or point in the right direction?
User avatar
shevman
Moderator
Moderator
 
Posts: 83
Joined: Thu Mar 20, 2014 8:34 pm

Re: imdb_id wrong or missing

Postby aussie_huddo » Thu Mar 09, 2017 7:47 am

I don't think so. The only ID stored in the kodi database is the IMDB ID so that is the only one that can be used for looking up artwork. The problem seems to be on the fanart.tv end on those links that I posted where the IMDB ID is not stored or is wrong.

How are those pages generated? where is it getting the IMDB ID from?
aussie_huddo
 
Posts: 11
Joined: Sat Mar 21, 2015 7:27 am

Re: imdb_id wrong or missing

Postby shevman » Thu Mar 09, 2017 2:00 pm

I'm not sure, but it seems to me that you don't know how to use Artwork Downloader, or am I mistaken?
User avatar
shevman
Moderator
Moderator
 
Posts: 83
Joined: Thu Mar 20, 2014 8:34 pm

Re: imdb_id wrong or missing

Postby aussie_huddo » Fri Mar 10, 2017 3:32 am

shevman wrote:I'm not sure, but it seems to me that you don't know how to use Artwork Downloader, or am I mistaken?

What are you talking about?

Artwork Downloader works fine for all other movies in my collection except the ones I posted. I noticed there was an issue and used the debug feature of Kodi to find that it was using the IMDB ID to look up artwork and since these movies have missing or wrong IDs on the fanart URLs I posted it was unable to find the artwork.

I am now trying to remedy the issue with the SOURCE of the problem, but it seems you don't know how your own site works. Is there anyone on the admin or mod team who would know how these webpages are generated and how to alter the IDs?
aussie_huddo
 
Posts: 11
Joined: Sat Mar 21, 2015 7:27 am

Re: imdb_id wrong or missing

Postby shevman » Fri Mar 10, 2017 7:09 am

If I didn't know that, then I would not get involved in this thread!
Here's what I tell you, I checked all IDs according to TMDb and they all have the correct ID!
All ID on Fanart, match with ID TMDb
and all ID TMDb match with ID IMDb

Here's how we get webpages:
1) we copy the ID
2) add ID to Fanart
3) we get webpages
1.png
1.png (183.55 KiB) Viewed 695 times

Here's how creating webpages TMDb:
1) copy the ID
2) add ID to TMDb
3) or check for the correct whether ID
2.png
2.png (164.8 KiB) Viewed 695 times

As I told you before, you probably need to ask on the forum Kodi, because the problem can be in your Kodi or "Artwork Downloader" or you doing something wrong.
What's stopping you from asking this on the Kodi forum, I don't understand you! :lol:
This thread is probably already read by many, and it seems that there is no one to add anything. I'm not sure, but it seems at 99% this problem is not related to fanart :D
Perhaps on this I will stop, because there is no sense to continue something.
User avatar
shevman
Moderator
Moderator
 
Posts: 83
Joined: Thu Mar 20, 2014 8:34 pm

Re: imdb_id wrong or missing

Postby aussie_huddo » Sun Mar 12, 2017 3:17 am

I'm not talking about the regular TMDB pages, I understand how they work.

I'm talking about the webpages that start with "webservice" which are used by artwork downloader to lookup artwork. Ones such as this one: http://webservice.fanart.tv/v3/movies/4 ... 284d46bd8e

Notice how the IMDB_ID field is blank? So when artwork downloader tries to look up the artwork using the IMDB ID "tt5973626" then a blank page is returned: http://webservice.fanart.tv/v3/movies/t ... 284d46bd8e

These are the webpages I'm interested to know how they are generated and what is causing them to not have the IMDB ID attributed to them
aussie_huddo
 
Posts: 11
Joined: Sat Mar 21, 2015 7:27 am

Re: imdb_id wrong or missing

Postby shevman » Sun Mar 12, 2017 7:21 am

Hey aussie_huddo, I understand you
but I really think you need to address in this thread http://forum.kodi.tv/showthread.php?tid=114633
I'm sure you would have already got your answer ;)
User avatar
shevman
Moderator
Moderator
 
Posts: 83
Joined: Thu Mar 20, 2014 8:34 pm


Return to Housekeeping

Who is online

Users browsing this forum: No registered users and 1 guest